re = /((?<!<[^>]*)> ((\d{1,}\.|-|\/\/|\%\%|\#) )?(\[[x ]\] )?)/m
str = '> - 测试
> - [ ] 测试
> - [x] 测试
> 1. 测试
> 2. [ ] 测试
> 2. [x] 测试
>
> - (✅)测试
> - [ ] (✅)测试
> - [x] (✅)测试
> 1. (✅)测试
> 2. [ ] (✅)测试
> 2. [x] (✅)测试
>
> 测试
> - 测试
> - [ ] 测试
> - [x] 测试
> <mark style="background: #ffcc33aa;">demo</mark> 测试
> // 测试
> %% 测试 %%
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end