const regex = /((?<!<[^>]*)> ((\d{1,}\.|-|\/\/|\%\%|\#) )?(\[[x ]\] )?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!<[^>]*)> ((\\d{1,}\\.|-|\\\/\\\/|\\%\\%|\\#) )?(\\[[x ]\\] )?)', 'gm')
const str = `> - 测试
> - [ ] 测试
> - [x] 测试
> 1. 测试
> 2. [ ] 测试
> 2. [x] 测试
>
> - (✅)测试
> - [ ] (✅)测试
> - [x] (✅)测试
> 1. (✅)测试
> 2. [ ] (✅)测试
> 2. [x] (✅)测试
>
> 测试
> - 测试
> - [ ] 测试
> - [x] 测试
> <mark style="background: #ffcc33aa;">demo</mark> 测试
> // 测试
> %% 测试 %%
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}