re = /webpush/m
str = 'dotproperty/webpush/alert
dotproperty/webpush/new-home
dotproperty/webpush/enquiry
dotproperty/webpush/loan-calc
dotproperty/webpush/alert?sort=newest'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end