#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)webpush"
Local $sString = "dotproperty/webpush/alert" & @CRLF & _
"dotproperty/webpush/new-home" & @CRLF & _
"dotproperty/webpush/enquiry" & @CRLF & _
"dotproperty/webpush/loan-calc" & @CRLF & _
"dotproperty/webpush/alert?sort=newest"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")