package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)webpush`)
var str = `dotproperty/webpush/alert
dotproperty/webpush/new-home
dotproperty/webpush/enquiry
dotproperty/webpush/loan-calc
dotproperty/webpush/alert?sort=newest`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}