import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "webpush";
final String string = "dotproperty/webpush/alert\n"
+ "dotproperty/webpush/new-home\n"
+ "dotproperty/webpush/enquiry\n"
+ "dotproperty/webpush/loan-calc\n"
+ "dotproperty/webpush/alert?sort=newest";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}