import Foundation
let pattern = #"^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
WPOZZZ97ZJL190335
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}