const regex = /^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$', '')
const str = `WPOZZZ97ZJL190335
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}