package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$`)
var str = `WPOZZZ97ZJL190335
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}