$re = '/^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$/';
$str = 'WPOZZZ97ZJL190335
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);