using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[S-Z]{1}[A-HJ-NPR-Z0-9]{12}[0-9]{4}$";
string input = @"WPOZZZ97ZJL190335
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}