# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^A-Za-z 0-9 \.,\?\"\"!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*"
test_str = ("aÇÃO\n"
"ANÃO\n"
"único\n"
"Único\n"
"íma\n"
"irmão")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.