import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^A-Za-z 0-9 \\.,\\?\"\"!@#\\$%\\^&\\*\\(\\)-_=\\+;:<>\\/\\\\\\|\\}\\{\\[\\]`~|\\xE0-\\xE6|\\xC0-\\xC6|\\xE8-\\xEB|\\xC8-\\xCB|\\xEC-\\xEF|\\xCC-\\xCF|\\xF2-\\xF6|\\xD2-\\xD6|\\xF9-\\xFC|\\xD9-\\xDC|\\xE7|\\xC7|\\xF1|\\xD1]*";
final String string = "aÇÃO\n"
+ "ANÃO\n"
+ "único\n"
+ "Único\n"
+ "íma\n"
+ "irmão";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}