const regex = /[^A-Za-z 0-9 \.,\?""!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^A-Za-z 0-9 \\.,\\?""!@#\\$%\\^&\\*\\(\\)-_=\\+;:<>\\\/\\\\\\|\\}\\{\\[\\]`~|\\xE0-\\xE6|\\xC0-\\xC6|\\xE8-\\xEB|\\xC8-\\xCB|\\xEC-\\xEF|\\xCC-\\xCF|\\xF2-\\xF6|\\xD2-\\xD6|\\xF9-\\xFC|\\xD9-\\xDC|\\xE7|\\xC7|\\xF1|\\xD1]*', 'g')
const str = `aÇÃO
ANÃO
único
Único
íma
irmão`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}