use strict;
my $str = 'aÇÃO
ANÃO
único
Único
íma
irmão';
my $regex = qr/[^A-Za-z 0-9 \.,\?""!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}