#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^A-Za-z 0-9 \.,\?""!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*"
Local $sString = "aÇÃO" & @CRLF & _
"ANÃO" & @CRLF & _
"único" & @CRLF & _
"Único" & @CRLF & _
"íma" & @CRLF & _
"irmão"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")