re = /^0*([1-9]\d{2,}|[5-9]\d)$/m
str = '00000001231343543
0678
000000000 657567
000657 76
00678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end