#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0*([1-9]\d{2,}|[5-9]\d)$"
Local $sString = "00000001231343543" & @CRLF & _
"" & @CRLF & _
"0678" & @CRLF & _
"" & @CRLF & _
"000000000 657567" & @CRLF & _
" 000657 76" & @CRLF & _
"00678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")