$re = '/^0*([1-9]\d{2,}|[5-9]\d)$/m';
$str = '00000001231343543
0678
000000000 657567
000657 76
00678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);