package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0*([1-9]\d{2,}|[5-9]\d)$`)
var str = `00000001231343543
0678
000000000 657567
000657 76
00678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}