const regex = /^0*([1-9]\d{2,}|[5-9]\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0*([1-9]\\d{2,}|[5-9]\\d)$', 'gm')
const str = `00000001231343543
0678
000000000 657567
000657 76
00678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}