// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)").unwrap();
let string = "Veja minha imagem aqui: www.imagem.com.br/imagem.jpg
Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png
Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif
Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}