using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)";
string input = @"Veja minha imagem aqui: www.imagem.com.br/imagem.jpg
Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png
Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif
Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}