re = /(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)/
str = 'Veja minha imagem aqui: www.imagem.com.br/imagem.jpg
Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png
Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif
Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end