#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)"
Local $sString = "Veja minha imagem aqui: www.imagem.com.br/imagem.jpg" & @CRLF & _
"Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png" & @CRLF & _
"Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif" & @CRLF & _
"" & @CRLF & _
"Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")