use strict;
my $str = 'Veja minha imagem aqui: www.imagem.com.br/imagem.jpg
Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png
Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif
Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png';
my $regex = qr/(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}