import Foundation
let pattern = #"^[a-zA-Z_\-][a-zA-Z0-9_\-]*(?:[ ]+(?:(?:[a-zA-Z_\-][a-zA-Z0-9_\-]*)))*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"class1 class-2 class__35--opa"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}