using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z_\-][a-zA-Z0-9_\-]*(?:[ ]+(?:(?:[a-zA-Z_\-][a-zA-Z0-9_\-]*)))*$";
string input = @"class1 class-2 class__35--opa";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}