#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-zA-Z_\-][a-zA-Z0-9_\-]*(?:[ ]+(?:(?:[a-zA-Z_\-][a-zA-Z0-9_\-]*)))*$"
Local $sString = "class1 class-2 class__35--opa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")