re = /^[a-zA-Z_\-][a-zA-Z0-9_\-]*(?:[ ]+(?:(?:[a-zA-Z_\-][a-zA-Z0-9_\-]*)))*$/
str = 'class1 class-2 class__35--opa'
# Print the match result
str.match(re) do |match|
puts match.to_s
end