import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z_\\-][a-zA-Z0-9_\\-]*(?:[ ]+(?:(?:[a-zA-Z_\\-][a-zA-Z0-9_\\-]*)))*$";
final String string = "class1 class-2 class__35--opa";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}