$re = '/^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}/m';
$str = '<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.yoti.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email yoti</string>
<string name="loc.component.help.email.label">Email YoTi</string>
<string name="loc.component.help.email.label">Email YOTI</string>
<string name="loc.component.help.email.label">Email YO.TI</string>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);