package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}`)
var str = `<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.yoti.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email yoti</string>
<string name="loc.component.help.email.label">Email YoTi</string>
<string name="loc.component.help.email.label">Email YOTI</string>
<string name="loc.component.help.email.label">Email YO.TI</string>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}