#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}"
Local $sString = "<string name="loc.component.help.email.label">Email EasyID</string>" & @CRLF & _
"<string name="loc.component.help.email.label">Email EasyID</string>" & @CRLF & _
"" & @CRLF & _
"<string name="loc.component.yoti.help.email.label">Email EasyID</string>" & @CRLF & _
"" & @CRLF & _
"<string name="loc.component.help.email.label">Email yoti</string>" & @CRLF & _
"<string name="loc.component.help.email.label">Email YoTi</string>" & @CRLF & _
"<string name="loc.component.help.email.label">Email YOTI</string>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<string name="loc.component.help.email.label">Email YO.TI</string>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")