use strict;
my $str = '<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email EasyID</string>
<string name="loc.component.yoti.help.email.label">Email EasyID</string>
<string name="loc.component.help.email.label">Email yoti</string>
<string name="loc.component.help.email.label">Email YoTi</string>
<string name="loc.component.help.email.label">Email YOTI</string>
<string name="loc.component.help.email.label">Email YO.TI</string>
';
my $regex = qr/^(<string name=\"){1}[\w.]+(\">){1}[\w ]+(?i)yoti(</string>){1}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}