import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(<string name=\\\"){1}[\\w.]+(\\\">){1}[\\w ]+(?i)yoti(</string>){1}";
final String string = "<string name=\"loc.component.help.email.label\">Email EasyID</string>\n"
+ "<string name=\"loc.component.help.email.label\">Email EasyID</string>\n\n"
+ "<string name=\"loc.component.yoti.help.email.label\">Email EasyID</string>\n\n"
+ "<string name=\"loc.component.help.email.label\">Email yoti</string>\n"
+ "<string name=\"loc.component.help.email.label\">Email YoTi</string>\n"
+ "<string name=\"loc.component.help.email.label\">Email YOTI</string>\n\n\n"
+ "<string name=\"loc.component.help.email.label\">Email YO.TI</string>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}