package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`RT(\A|\s)@(\w)+`)
var str = []byte(`RT @iamkhiofficial2323: #lahore #LahoreBlasts : #punjabgovt 9 #dead. 20 #injured. https://t.co/UU7doEtTmZ #pray #unite #notgivingup RT @iamkhiofficial2323
RT @iamkhiofficial2323`)
var substitution = []byte("<label class="">$0</label>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}