# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([a-z-@/0-9\.-]+)\"(: \".+\",?\n)"
test_str = ("\"@typescript-eslint/eslint-plugin\": \"^4.14.0\",\n"
"\"@typescript-eslint/parser\": \"^4.14.0\",\n"
"\"babel-eslint\": \"^10.1.0\",\n"
"\"eslint\": \"7.2.0\",\n"
"\"eslint-config-airbnb\": \"18.2.1\",\n"
"\"eslint-config-prettier\": \"^7.2.0\",\n"
"\"eslint-plugin-import\": \"^2.22.1\",\n"
"\"eslint-plugin-jam3\": \"^0.2.3\",\n"
"\"eslint-plugin-jsx-a11y\": \"^6.4.1\",\n"
"\"eslint-plugin-prettier\": \"^3.3.1\",\n"
"\"eslint-plugin-react\": \"^7.21.5\",\n"
"\"eslint-plugin-react-hooks\": \"4.0.0\",\n")
subst = "$1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.