import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([a-z-@/0-9\\.-]+)\"(: \".+\",?\\n)";
final String string = "\"@typescript-eslint/eslint-plugin\": \"^4.14.0\",\n"
+ "\"@typescript-eslint/parser\": \"^4.14.0\",\n"
+ "\"babel-eslint\": \"^10.1.0\",\n"
+ "\"eslint\": \"7.2.0\",\n"
+ "\"eslint-config-airbnb\": \"18.2.1\",\n"
+ "\"eslint-config-prettier\": \"^7.2.0\",\n"
+ "\"eslint-plugin-import\": \"^2.22.1\",\n"
+ "\"eslint-plugin-jam3\": \"^0.2.3\",\n"
+ "\"eslint-plugin-jsx-a11y\": \"^6.4.1\",\n"
+ "\"eslint-plugin-prettier\": \"^3.3.1\",\n"
+ "\"eslint-plugin-react\": \"^7.21.5\",\n"
+ "\"eslint-plugin-react-hooks\": \"4.0.0\",\n";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}