re = /^\d+$/im
str = 'сгущенка
привет сгущенка как тдеда
92 наоборот
92 наобот
skalik92 хай!
(?<!skalik)92
92
14
96
95 asfasdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end