using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+$";
string input = @"сгущенка
привет сгущенка как тдеда
92 наоборот
92 наобот
skalik92 хай!
(?<!skalik)92
92
14
96
95 asfasdf
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}