#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\d+$"
Local $sString = "сгущенка" & @CRLF & _
"привет сгущенка как тдеда" & @CRLF & _
" 92 наоборот" & @CRLF & _
"92 наобот" & @CRLF & _
"skalik92 хай!" & @CRLF & _
"(?<!skalik)92" & @CRLF & _
"92" & @CRLF & _
"14" & @CRLF & _
"96" & @CRLF & _
"95 asfasdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")