const regex = new RegExp('^\\d+$', 'gim')
const str = `сгущенка
привет сгущенка как тдеда
92 наоборот
92 наобот
skalik92 хай!
(?<!skalik)92
92
14
96
95 asfasdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}