package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\d+$`)
var str = `сгущенка
привет сгущенка как тдеда
92 наоборот
92 наобот
skalik92 хай!
(?<!skalik)92
92
14
96
95 asfasdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}