$re = '/休憩\S*\s*(なし|無し)/m';
$str = '休憩なし
休憩:なし
休憩時間: 無し
休憩 無し
休憩 なし';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);