import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "休憩\\S*\\s*(なし|無し)";
final String string = "休憩なし\n"
+ "休憩:なし\n"
+ "休憩時間: 無し\n"
+ "休憩 無し\n"
+ "休憩 なし";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}