using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"休憩\S*\s*(なし|無し)";
string input = @"休憩なし
休憩:なし
休憩時間: 無し
休憩 無し
休憩 なし";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}