#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)休憩\S*\s*(なし|無し)"
Local $sString = "休憩なし" & @CRLF & _
"休憩:なし" & @CRLF & _
"休憩時間: 無し" & @CRLF & _
"休憩 無し" & @CRLF & _
"休憩 なし"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")