package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)休憩\S*\s*(なし|無し)`)
var str = `休憩なし
休憩:なし
休憩時間: 無し
休憩 無し
休憩 なし`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}