import Foundation
let pattern = #"^\[[^]]+\]: builds\/app\/(.+?)\.(ipa|apk)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: [32m--- Step: Switch to android upload_to_s3 lane ---[0m
[14:54:35]: [32m-------------------------------------------------[0m
[14:54:35]: Cruising over to lane 'android upload_to_s3' 🚖
[14:54:37]: builds/app/oneoff/android/22.26.2_15_225877//app-oneoff-release.apk
[14:54:37]: Cruising back to lane 'android build_oneoff' 🚘
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}